Cacic funciona 100% no Slackware

Recentemente fiz a instalação do software de inventário Cacic na versão 11 do Slackware e o resultado foi de 100%. Tudo funcionou sem maiores problemas, porém é claro que foi necessário refazer, ou melhor, recompilar o PHP, mas somente isso. 😉

A nova versão 2.2.2 acho que é esse o número da última versão… é muito, mas muito mais fácil a instalação! Você apenas salva os arquivos no diretório onde o Servidor web possa acessar e através do browser você cria o banco de dados e verifica as dependências necessárias para a instalação do cacic.

Abaixo, vou tentar descrever o que deve ser feito para o cacic funcionar com o slackware. São passos simples que devem ser tomados:

A primeira coisa a fazer é baixar os pacotes da biblioteca mcrypt. Essa biblioteca é necessária para a criptografia, porém o [php ] que vem no slackware, tanto o php4 quanto o php5, não possuem suporte a essa bilbioteca.

Essa biblioteca pode ser baixada no SF, mas aí vai o link direto: http://sourceforge.net/project/showfiles.php?group_id=87941

A instalação é simples.

 tar pacote.tar.gz ; ./configure ; make ; make install ; ldconfig

Detalhe: primeiro compile a Libmcrypt e em seguida a MCrypt.

Após, a instalação da bilioteca, baixe o SlackBuild do PHP e todo o conteúdo do diretório, segue o link para o PHP4: http://ftp.belnet.be/packages/slackware/slackware-11.0/source/n/php/
Para compilar o PHP é necessário baixar também o pine (http://ftp.belnet.be/packages/slackware/slackware-11.0/source/n/pine/).

Após baixar todos os pacotes você deve ter uma estrutura semelhante à:

  |

  |

  |/pacotes

  	|/php

  	|/pine

Não esqueça de deixar os scripts de compilação php.SlackBuild e pine.SlackBuild com permissão de execução (chmod +x).
Agora basta incluir dentro do php.Slackbuild a seguinte linha:

Antes,

  --disable-debug 

  --with-zlib=/usr

  # --with-mod_charset    # only for Russian patched Apache

  # --with-readline=/usr  # this is only for the CGI version

Depois,

  --disable-debug 

  --with-zlib=/usr 

  --with-mcrypt=/usr      <-----------ESSA É A LINHA QUE DEVE SER INCLUÍDA

  # --with-mod_charset    # only for Russian patched Apache

  # --with-readline=/usr  # this is only for the CGI version

Agora é só executar: ./php.SlackBuild

Reinstale o pacote do php reinicie o Apache (/etc/rc.d/rc.httpd restart) e acesse o cacic. Com esses passos todas as dependências são solucionadas. 😉

Boa sorte!!

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google

Você está comentando utilizando sua conta Google. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s

Site no WordPress.com.

Acima ↑

%d blogueiros gostam disto: